Cloud Timeouts
Incident Report for Appspace
Resolved
All logins are functioning normally as of now. The issue was related to upstream network connectivity timeouts with our cloud service provider.
Posted May 18, 2020 - 16:40 CDT
Investigating
We are currently investigating timeouts across all cloud servers.
Posted May 18, 2020 - 16:17 CDT
This incident affected: Global (Cloud Authentication).