Public Cloud Performance Degradation

Incident Report for Appspace

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 16:09 CDT

Update

After implementing the fix the Appspace platform is no longer experiencing degraded performance and is fully operational.
Posted Apr 06, 2026 - 16:09 CDT

Monitoring

A fix has been implemented and we are monitoring improvements
Posted Apr 03, 2026 - 13:42 CDT

Investigating

We are currently investigating reports of intermittent issues and slow performance within the Appspace platform. Our engineering team is looking into the root cause, and we will provide an update as soon as more information is available.
Posted Mar 30, 2026 - 08:00 CDT
This incident affected: Global (Public Cloud Environment).