Unable to download content from library in Public Cloud

Incident Report for Appspace

Resolved

The fix implemented is working as intended, this issue is now resolved.
Posted Apr 29, 2025 - 14:42 CDT

Monitoring

A fix has been implemented and we are continuing to monitor.
Posted Apr 29, 2025 - 12:32 CDT

Update

We are continuing to investigate this issue.
Posted Apr 29, 2025 - 11:26 CDT

Investigating

We are experiencing a disruption impacting content downloads from the Library for users in our Public Cloud environment. Our teams are actively working on resolving the issue. Wi
Posted Apr 29, 2025 - 11:25 CDT
This incident affected: Global (Public Cloud Environment).