Public Cloud Download Page Currently Unavailable

Incident Report for Appspace

Resolved

This underlying issues has been Identified and resolved. App packages can be accessed and downloaded.
Posted Nov 25, 2025 - 15:03 CST

Update

We are continuing to investigate this issue.
Posted Nov 25, 2025 - 14:42 CST

Investigating

We're currently investigating reports that the Public Cloud Download Page is inaccessible. Users cannot access any app packages when trying to access the page or download resources.
Posted Nov 25, 2025 - 14:41 CST
This incident affected: Global (Public Cloud Environment).