Login Failures and Slow Authentication on Public Cloud

Incident Report for Appspace

Resolved

The fix that was applied has resolved the issue.
Posted Oct 27, 2025 - 16:32 CDT

Monitoring

The issue has been identified and a fix has been applied. We will continue to monitor to ensure platform stability.
Posted Oct 27, 2025 - 11:18 CDT

Investigating

We are currently investigating reports of slow or failed login attempts impacting users on the Public Cloud environment. Affected users may experience delays during authentication or receive timeout errors when attempting to sign in.
Posted Oct 27, 2025 - 10:52 CDT
This incident affected: Global (Public Cloud Environment).