Intermittent Login Issues and Degraded Performance on Public Cloud

Incident Report for Appspace

Resolved

The issue was identified and remediated. The Public Cloud environment is operational.
Posted Mar 10, 2026 - 13:40 CDT

Investigating

We are currently investigating reports of intermittent login failures and performance degradation affecting our Public Cloud environments.
Posted Mar 10, 2026 - 08:36 CDT
This incident affected: Global (Public Cloud Environment).