Degraded Performance with Sign-Ups

Incident Report for Appspace

Resolved

Our Engineering team has applied a fix, and confirmed that invite sign up is working as intended.
Posted Mar 11, 2025 - 10:12 CDT

Investigating

We are currently experiencing degraded performance affecting new user sign-ups. Some users may encounter a “This is embarrassing” error when creating a new account. Our team is actively investigating the issue and working on a fix.

We appreciate your patience and will provide updates as soon as we have more information.
Posted Mar 06, 2025 - 17:32 CST
This incident affected: Global (Cloud Authentication).