Login and Performance Issues Affecting Public Cloud Servers

Incident Report for Appspace

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 12:37 CDT

Monitoring

A fix has been deployed and we're seeing positive performance improvements.
Posted Jul 01, 2026 - 14:48 CDT

Investigating

We are currently investigating reports of users being unable to log in to public cloud servers, along with reports of slow performance. Some customers may experience authentication failures, timeouts, or degraded response times. We will update once we have identified the issue.
Posted Jul 01, 2026 - 08:41 CDT
This incident affected: Global (Public Cloud Environment).