Login Latency & General Performance
Incident Report for Appspace
Resolved
This incident has been resolved. Normal performance has returned.
Posted May 22, 2023 - 19:00 CDT
Investigating
We are seeing latency logging into the Appspace Public Cloud as well as latency when navigating within Appspace. We are working with our Cloud partner to identify root cause on the Cloud Platform.
Posted May 22, 2023 - 18:12 CDT
This incident affected: Global (Cloud Authentication, Public Cloud Environment).