Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 14:00 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 24, 2025 - 10:16 CDT
Scheduled
NOTE: The exact time of this release may vary depending on device platform as well as specific device configurations for device updates.
Appspace App for Devices v2.81.0 will be released. This release will be for the following platforms:
Public Cloud Downloads page (Android, BrightSign, LG WebOS, MacOS, Windows, Ubuntu, UWP WebView 2, Tizen) Electron Artifacts on cloud.appspace.com/update (Both Windows and MacOS) Public PWA (cloud.appspace.com/app) Private Cloud Instances PWA 8.4.0-ac.3 and above Google Play Store Apple App Store Chrome Store Windows Store Snap Store BrightSign BSN on Google Storage Tizen hosted package (https://cloud.appspace.com/device/tizen)