Issues Accessing Preview and Public Cloud Download Packages

Incident Report for Appspace

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 19:24 CST

Investigating

We are currently investigating an issue where some users may find the Preview and Public Cloud downloads page is not displaying the full list of available download packages.
Posted Jan 28, 2026 - 16:16 CST
This incident affected: Global (Public Cloud Environment, Preview Cloud).