App13 performance issues
Incident Report for Appspace
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 14:38 CST
Update
We are continuing to investigate this issue.
Posted Nov 16, 2023 - 08:12 CST
Investigating
We are currently investigating this issue.
Posted Nov 16, 2023 - 08:11 CST
This incident affected: North America (APP13 (formerly NC01) Environment).