App13 and App15 degraded performance after update
Incident Report for Appspace
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 07:43 CDT
Investigating
We are currently investigating this issue.
Posted Jun 03, 2024 - 07:19 CDT
This incident affected: Europe (APP15 Environment) and North America (APP13 (formerly NC01) Environment).