Public Cloud Performance Degradation

Incident Report for Appspace

Resolved

The changes applied over the weekend have remained stable and performance is back to normal.
Posted May 05, 2026 - 09:44 CDT

Update

Performance has returned for Public Cloud. Both the Cloud Platform and Engineering team are monitoring to ensure performance continues.
Posted May 01, 2026 - 13:05 CDT

Update

We are continuing to monitor for any further issues.
Posted May 01, 2026 - 13:04 CDT

Monitoring

The Public Cloud Platform performance is improving, and our Engineering team is continuing to work to further improve performance.
Posted May 01, 2026 - 12:19 CDT

Identified

Our Engineering team is continuing to work to solve the underlying performance issue that is impacting Public Cloud. We will continue to provide updates and once we have an ETA for resolution, we will update accordingly.
Posted May 01, 2026 - 11:12 CDT

Update

We are continuing to work on resolving the ongoing performance issues. Some slowness may still be observed. We will share another update as soon as more progress has been made.
Posted May 01, 2026 - 09:14 CDT

Update

Our team is continuing to implement fixes to address the ongoing performance issues. Some slowness may still be observed during this time.
Posted Apr 30, 2026 - 10:01 CDT

Monitoring

We have deployed a fix that has improved overall performance. Some slowness may still be observed, and our team continues to monitor and investigate.
Posted Apr 29, 2026 - 12:13 CDT

Update

We are still activity investigating this issue.
Posted Apr 29, 2026 - 11:10 CDT

Investigating

We have noticed this issue reoccurring with intermittent login failures. We are continuing to investigate
Posted Apr 29, 2026 - 08:27 CDT

Monitoring

We have implemented a fix and are continuing to monitor
Posted Apr 28, 2026 - 14:05 CDT

Investigating

We are currently experiencing an outage affecting our public clouds. Some or all services may be unavailable or responding slowly. Our team is actively investigating.
Posted Apr 28, 2026 - 12:11 CDT
This incident affected: Global (Public Cloud Environment).